🐹 Nextcloud ошибка: «В системе не установлены рекомендуемые модули PHP. Для улучшения производительности и совместимости рекомендуется установить эти модули: bcmath, gmp».

Содержание:

1. Признаки ошибки.
2. Исправление ошибки.
3. Оригиналы источников информации.


1. Признаки ошибки.

Нашел ты такой обновления Nextcloud на официальном сайте, радостно установил их… И тут Nextcloud тебе жалуется во вкладке Общие сведения

Были обнаружены ошибки конфигурации.

  • В системе не установлены рекомендуемые модули PHP. Для улучшения производительности и совместимости рекомендуется установить эти модули.
    • bcmath
    • gmp

Хотя все было обновлено по инструкции, без повреждений, права на каталоги и файлы выставлены верно.

2. Исправление ошибки.

Установим недостающие модули PHP:

# yum -y install php-bcmath

# yum -y install php-gmp

Перезапускаем php-fpm:

# systemctl restart php-fpm

Перезапустим nginx:

# systemctl restart nginx

Открываем Общие сведения и всё в порядке.

Ошибка исправилась!

3. Оригиналы источников информации

Нет.

Читайте также: